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Warranty and Liability

Warranty and Liability

Note The Application Examples are not binding and do not claim to be complete with
regard to configuration, equipment or any contingencies. The Application
Examples do not represent customer-specific solutions. They are only intended
to provide support for typical applications. You are responsible for the correct
operation of the described products. These Application Examples do not relieve
you of the responsibility of safely and professionally using, installing, operating
and servicing equipment. When using these Application Examples, you
recognize that we cannot be made liable for any damage/claims beyond the
liability clause described. We reserve the right to make changes to these
Application Examples at any time and without prior notice. If there are any
deviations between the recommendations provided in this Application Example
and other Siemens publications — e.g. Catalogs — the contents of the other
documents shall have priority.

We do not accept any liability for the information contained in this document.

Any claims against us — based on whatever legal reason — resulting from the use of the
examples, information, programs, engineering and performance data etc., described in this
Application Example shall be excluded. Such an exclusion shall not apply in the case of
mandatory liability, e.g. under the German Product Liability Act (“Produkthaftungsgesetz”), in
case of intent, gross negligence, or injury of life, body or health, guarantee for the quality of a
product, fraudulent concealment of a deficiency or breach of fundamental contractual
obligations (“wesentliche Vertragspflichten™). The compensation for damages due to a breach of
a fundamental contractual obligation is, however, limited to the foreseeable damage, typical for
the type of contract, except in the event of intent or gross negligence or injury to life, body or
health. The above provisions do not imply a change of the burden of proof to your detriment.

Any form of duplication or distribution of these Application Examples or excerpts hereof is
prohibited without the expressed consent of Siemens AG.

Security  Sijemens provides products and solutions with industrial security functions that
informa-  support the secure operation of plants, solutions, machines, equipment and/or
tion networks. They are important components in a holistic industrial security
concept. With this in mind, Siemens’ products and solutions undergo continuous
development. Siemens recommends strongly that you regularly check for
product updates.

For the secure operation of Siemens products and solutions, it is necessary to
take suitable preventive action (e.qg. cell protection concept) and integrate each
component into a holistic, state-of-the-art industrial security concept. Third-party
products that may be in use should also be considered. For more information
about industrial security, visit http://www.siemens.com/industrialsecurity.

To stay informed about product updates as they occur, sign up for a product-
specific newsletter. For more information, visit
http://support.industry.siemens.com.
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1 LOGO! App for LOGO! 8 and LOGO! 7

1 LOGO! App for LOGO! 8 and LOGO! 7

1.1 Overview of functions

Using the free of charge LOGO! App enables you to update the current process values of your LOGO! 8 and
LOGO! 7 application with your smart phone or tablet PC via WLAN or Internet. This allows for switching digital
signals as well as changing analog setpoint values. Calling up diagnostic values is also possible via the
LOGO! App.

Your LOGO! App enables you ...

... to configure connections to more than one LOGO!

For each LOGO! connection you can assign your own
= : profile with user-defined connection name and IP address.
ype
o8A7 [l oBAs

&« Create Connection B

This enables the later distinction between several
connections or configured values.
i Access to each individual LOGO! connection can be
LOGO!8 Test PLC protected by a separate password.

IP Address / Hostname

192.168.56.132

Username

App User

Password

1234557890“
el J-A+4-M«0cDf/ ] I
SHE]

et . set apassword for the LOGO! App
SetP d i
et Fasswor To protect the general access to the App you can specify a
Please set password to protect your configuration data. If left blank, no password is set. reSpeCtIVe password for your App .

Enter New Password:

... In addition, you can assign a separate password for each
configured LOGO! connection.

Confirm New Password:
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s .. modify and display values in a table

& Tag List + 7 . . .
Configured values in the LOGO! program, such as function

Name: b0O1 block parameters or network I/O, can be represented in a

table and modified.

Value: 4

Name: b003

Value: 0

Name: b027

Value: 0

Name: B029

Value: 0

AW

« Trendview ... graphic display of values

Several of the configured values can be selected in the
table and be graphically displayed in a trend view. A further
configuration of the trend view is not necessary. The scale
is adjusted automatically; in addition, the user-specific
name of the selected values and the actual address are
displayed.

B Value1 (+192) B Value2 (-16384)

B value3 (0)
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1 LOGO! App for LOGO! 8 and LOGO! 7

1P:192.168.56.86 weer ., edit the LOGO! date and time
< SetClockon PLC Furthermore, the LOGO! date and time can be read,
Date: manually modified or be adapted to the current date and
02122014 time of the mobile device.
Time:
09:44 AM
% p
07 42
08 43
09 44 AM

10
1n ’
12

45
46
a7

Note Operating the plant on site, for example with LOGO! Text Display or SIMATIC
Panel, is not affected by the LOGO! App and can be performed simultaneously

Further information is available at:  http://www.siemens.de/logo

1.2 Download of the LOGO! App

Link to the download versions:
http://w3.siemens.com/topics/global/en/industry/future-of-manufacturing/industry-apps/Pages/industry-

apps.aspx

QR code for

SIMATIC 2go

page



http://w3.siemens.com/mcms/programmable-logic-controller/en/logic-module-logo/Pages/Default.aspx
http://w3.siemens.com/topics/global/en/industry/future-of-manufacturing/industry-apps/Pages/industry-apps.aspx
http://w3.siemens.com/topics/global/en/industry/future-of-manufacturing/industry-apps/Pages/industry-apps.aspx
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2 Instruction

2.1 Default settings and creating a connection with LOGO!

211 Specifying the password and access for the LOGO! App in LOGO! Soft Comfort

Prior to accessing LOGO! via the LOGO! App you need to enable the access in the respective
LOGO! controller as well as define a password for this access. These settings must be made in
LOGO! SoftComfort V8 and be loaded into LOGO!.

Proceed as follows:

= LOGO!Soft Comfort

Fie Edt Format Vie II indow _Help

. DiagramMode | if Determine LOGO! = ? LOGO! > PC Criu
f  stantLoco!
Select Hardware. ctrisn F | ]
R SteplL0GO!
v | Diagrams i
" Add New Diagram D, CtrieMinus Synchronize clock with EM [ B ]
° (OGO APLYS |90 simution = Show F version

Clear User Program and Password

Upload Data Log

Simulation Parameters.

€1 Connect Modem.
| Instructions €% Disconect Modem EEE b
B Titrs:tioes 5 Configure Master/Siave Mode.
b Gt g Ethemet Connections... Set Clock
« ] Digital Parameter Vi Mapping Summer time/Winter time.
! Input 5t LOGO!TD Power-on Screen

Optons.

F LOGO! TD Function key
§ Shift register bit . Hours counter.

Interface
Connect through: Ethemet - LANT7500 USB 2.0 to Ethemet 10/100/1000 Adapter - |

Target

; = m
Target IP address] 192 168. 0. 10 Address book

Accessidle LOGOL o
Name P Address Subnet Mask Gateway MAC address Status

[ 5 Intedtace = |

Connect o LOGO!

Show FW version ESOA .
Assign IP address
Setdlock Enable password protection for remote access
Operating mode
Clear program and password
TD power-on screen Enter'mew password
Hours Counter New password:
Upload detalog Confirm New Password:
Diagnostics
SummerWinter time
oo o Apply
Dynamic server IP fiter ‘Allow LOGO! App access.

Clock Sync with EM Switch 7] Allow LOGO! App access

7] Enable password protection for LOGO! App access

Enter new password
New password. @00 @
Confim New Password. 000 @

i
===
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In LOGO!Soft Comfort V8 you navigate to
“Tools > Transfer > Access Control”.

Select the “Interface” for your connection to LOGO! and
enter the IP address of your LOGO!. Click “Test” in order to
check whether the connection is successful. If the
connection is successful click “OK” in order to load the
program into the device.

Navigate to menu item “Access control settings” via the
“Online settings” tab in “File > Properties”.

¢ Activate the “Allow LOGO! App access” checkbox.
¢ Activate the “Enable password protection for LOGO! App
access” checkmark.

e Assign a password. This password must be identical
with the respective password for the LOGO! connection
in your LOGO! App!

(Device view of the respective LOGO! connection in the
LOGO! App)

¢ Click on “Apply” to accept the password.
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212

Set Password
Please set password to protect your configuration data. Ifeft blank, no password s set

Enter New Password:

Confirm New Password

<« Create Connection L]

Type
osw7 M| o8hs

Name

LOGO! 8 Test PLC

1P Address / Hostname

192.168.56.132

*) Note

Settings in the LOGO! App

1. Password LOGO! App
When using LOGO! App for
the first time, the password
mask in which you can
specify a password for the
LOGO! App appears.
(Respective specification in
the “Settings” mask later on
is also possible)

This password is only
used for logging on to
LOGO! App. Access to
the respective LOGO!
controller is specified in
the device overview

2. Device overview
Subsequently, you are
directed to Device
Overview.

In this screen you can add
new LOGO! devices (plus)
or edit existing connections
(pen).

You can also choose the
Settings menu or the
Information dialog here.
(Spanner and info button)

3. Connections

In the “Create connection”
mask you connect your
mobile device to LOGO!

- The name refers to the
connection and can be
assigned by the user.

- In IP Address you enter
the IP address of your
LOGO! %)

- User name “App User” is
default.

- In Password you enter the
PW of your LOGO!
controller, which you have
specified via LOGO!Soft
Comfort.

address space. For example:

IP address LOGO!: 192.168.0.10
IP address WLAN: 192.168.0.x

Brief instruction for LOGO! App
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Device Overview

L0GO! 0BAT
192.168.56.86

L0GO! 0BAB
192168.56.99

LOGO! & Home
192.168.56.55

2 i

L0GO! 7 Garage
19216856132

o

,

4. Device overview
After the connection with
LOGO! has been
established, you are taken
back to the device
overview where your
specified LOGO!
connections are displayed.

Add connections to further
LOGO! devices with “+”

5. Check connection
Selecting the respective
LOGO! in the device
overview takes you to the
station information mask.

For an existing connection
with LOGO!, the current
state (RUN/STOP) and the
firmware of LOGO! is
shown.

Settings

In menu item Settings, you
can additionally specify

- Language,

- Refresh frequency

- and App password.

Your WLAN access point and the LOGO! must be located in the same IP
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2.2

logo test
FW: V1.08.01

10 Status
Variables

Set Date and Time

221

<« 10 State Selection

Analog Output

Analog Flags

LOGO! TD Function Keys

<« Outputs.
Time/Data @ @ @ @ o e o e 0
093421 o o 0
09:3421 o o
09:3420
09:3420
093419
093419
093418
093418
093417
093417
093416
093416
093415

o
o
o
0
0
0
o
0
0
o
0
0
0
09:34:15 o
0

09:34:14
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Working with LOGO! App

1/O State Selection

In “10 State Selection” you
can access the status
displays of inputs and
outputs, flags of the LOGO!
keys, and the text display.

Some examples of status
displays are given in further
screens on this page.

Outputs

Pressing “Outputs” shows
the state and a short state
history of the output
signals.

Starting point of the functions

In this “Station Info” overview mask the
following functions can be accessed via
the called masks:

e view |O status,

e view and change variables,
e set LOGO! date and time.

Status displays of inputs/outputs, flags, and keys

Trendview
“‘\“ e

‘H\J‘H

Trendview

)

Trendview outputs

The # icon takes you to

the Trendview mask where
you can view the values in
a graphic display.

Trendview analog values

The 2 icon takes you to
the Trendview mask where
you can view the analog
values in a graphic display.
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222 Displaying and changing LOGO! variables

Digital and analog network inputs

Analog FB parameters

E Variable Memory Configuration @
D Block Parameter Type Address
1 a3 B0O1 [PI controller] PV, amplified C¥ Word 2
| 2 73 B001 [PI controller] aQy Word 4
| 3 pu BOO2 [Asynchronous Pulse Generator]  Pulse Width (TH) j Word 6
| 4 1 B0O02 [Asynchronous Pulse Generator] Interpulse Width (TL) ] Word 8
5 B002 [Asynchronous Pulse Generator] Pulse Width (TH) Time Base j Byte 10
6 uu B002 [Asynchronous Pulse Generator] Interpulse Width (TL) Tim... ] Byte 11
7 ZZ B003 [Up/Down counter] Counter QC/ DWord 16
8
=a

Calling the variable in LOGO! App

&« Edit Tag

Name

b001

Format

UNSIGNED

BINARY
SIGNED
UNSIGNED
HEX

AsCll

7, Change value on PLC

12]s]a 5‘6‘7 s”g‘olg
| | | | | ]

——

B[ fc[]e]e]

gl I =

CITTTT11 8

ABC
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Digital and analog network inputs can be addressed directly
in LOGO! App using the respective V address.

In order to display or change analog FB parameters in
LOGO! App you need to enter these FB parameters into the
parameter VM table in LOGO! Soft Comfort. (Menu item
“Tools > Parameter VM assignment")

Q FB parameter - read only (actual value in LOGO!)

& FB parameter - read and write

Select the “Variables” mask in the “Station Info” mask.

e The address corresponds to the V address of your
network input or the FB parameter in the LOGO! program.
e Assign a name to the variable.

¢ In Format you select the display format for the variable.
For digital variables, select “BINARY”. For analog variables,
select the desired display format, for example UNSIGNED.

Enter the desired value in “New Value”. Tapping the “Write
to PLC” button accepts the value as current variable value
in LOGO!.
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2.2.3 Setting date and time

W(_W'W”h Set Clock on PLC 1 Date and tlme

Set date and time
individually by selecting
“Set Clock on PLC” in the
Station info.

[ oo | e o dc

aAxa
T T

Brief instruction for LOGO! App
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